MXNet fails to find mobile GPU (Mobile nvidia 1060GTX) under Windows10

I have tried running MXNet 1.3.1 with CUDA9.2 under Windows10 on a Dell Laptop that has both a Intel graphics adapter and a nVidia 1060GTX. Somehow when I use mx.gpu(0) as context on any ndarray operation withi this context I’ll get following error:

Message=[23:24:34] c:\jenkins\workspace\mxnet-tag\mxnet\src\engine\ Check failed: device_count_ > 0 (-1 vs. 0) GPU usage requires at least 1 GPU
C:\local\Anaconda3-4.1.1-Windows-x86_64\lib\site-packages\mxnet\ in check_call
C:\local\Anaconda3-4.1.1-Windows-x86_64\lib\site-packages\mxnet_ctypes\ in _imperative_invoke

Also when I mx.test_utils.list_gpus() I’ll get an empty list back. But MXNet seems to be the only software that I’ve got installed that is unable to fnd my mobile nVidia GPU other software that uses CUDA is well able to find the adapter. Has anyone else experienced problems like this and if yes how can I fix it so that I can use my mobile GPU?

How did you install MXNet? Did you set the context ctx = mx.gpu() ?

I installed it using the pip python package manager, e.g.

pip install mxnet-cu92-mkldnn.

Obviously I have installed CUDA9.2 and CUDNN7 as well.

But actually I am wrong I am still on 1.3.0 as 1.3.1 for some reason does not seem to work for me at all. It already fails on import mxnet

Yes I do set ctx = mx.gpu()

Solved it I simply had a too old nVidia driver installed once upgrading to a 41x series driver it all started working doh

I am glad it is working now :slight_smile: