Installation error by pip in Anaconda environment

I have already installed NVIDIA’s driver and CUDA in Ubuntu 16.04. And when I activate Anaconda environment and use pip to install mxnet or mxnet-cu*, there is an installation error showing like this:

(base) inin-aasmc@ININ-Z640:~$ conda --version
conda 4.5.11

(base) x@x:~$ conda activate python35
(python35) x@x:~$ pip install mxnet
Collecting mxnet
  Could not find a version that satisfies the requirement mxnet (from versions: )
No matching distribution found for mxnet

I use ‘pip install mxnet-cu92 -i’, there is still the same error as below.
I tried Python 3.6.5, 3.5.6 and 2.7.15 in anaconda environment, and the version of pip is latest.
But if I use pip of original python which is installed before anaconda, it works.

(base) x@x:~$ pip2 install mxnet-cu92 -i
Collecting mxnet-cu92
  Downloading (442.1MB)
    9% |███                             | 40.5MB 33.6MB/s eta 0:00:12

Is there no suitable version of mxnet for python in conda? I’m quite confused.
Maybe I would like to bulid it from source code next step.

Could you post ‘pip install mxnet -vvv’ and ‘pip list’? (First pip uninstall mxnet).
pip install mxnet is the recommended method of installing mxnet (cpu) and does work (


Hi Vishaal, thanks for your notice. I found all avaiable versions for mxnet is skipped by pip process, and then I solved it by reinstall the anaconda with 64-bits version.
Because the installed anaconda is 32-bits before, the installed python in vitural environment is also 32-bits. I guess mxnet must be supported with 64-bits environment, so it is okay now by reinstallation.

1 Like