Segfault when attempting to upgrade "symbol saved by previous version v0.8.0"

I’ve build the MXNet library for my Raspberry PI 3+ according to the documentation here: (Raspberry Pi section). Including OpenCV.

When I proceed with the Wine detector tutorial I get a Segfault:

pi@raspberrypi:~/incubator-mxnet/python $ python
Python 2.7.13 (default, Nov 24 2017, 17:33:09) 
[GCC 6.3.0 20170516] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import inception_predict
[09:02:43] src/nnvm/ Loading symbol saved by previous version v0.8.0. Attempting to 

“Segmentatiefout” is Dutch for “Segmentation fault”

I’ve tried the Squeezenet v1.1 model as well and this renders the same error. Is this a known issue? Anything I can do to solve this?

Without actually trying this on a Raspberry PI and assuming the crash is due to the conversion script, my best guess is that this is related to the build on Raspberry PI. If the same instructions work fine on linux, I’d suggest importing the saved model and re-exporting it (which will save it in the new format) for use on RaspberryPI so that the model conversion doesn’t have to run on RaspberryPI.

1 Like

Excellent suggestion! I just tried that and… still segfaulting. Turns out that my Raspberry Pi runs MXNet 1.3.0 (master?) and I’ve installed MXNet 1.2.0 on my Mac.

Now I’ve switched to branch v1.2.0 and the compile is running on my Raspberry Pi.

The v1.2.0 branch contains v1.2.1 so it’s still trying to upgrade… :disappointed:

>>> import inception_predict
[15:07:26] src/nnvm/ Loading symbol saved by previous version v1.2.0. Attempting to upgrade...

And does this crash? If not, then that could be fine. You can also always checkout the exact commit for official 1.2.0 and build at that commit to match 1.2.0. To tell what the commit hash is for an official release, you can look at the COMMIT_HASH file that is part of python package that gets installed with pip install.

Yes, this crashes as well… Might try to find the exact same release and try once more. I’m kind of disappointed that I need to be so persistent to get a simple tutorial up and running.

I’ve reopened a previously unresolved issue on the Github project. Let’s see if somebody knows how to fix it properly so we can make it a step more friendly to get started with.

Here’s the issue: