Reshape error calling ctypes

Here trying to learn MXNET with “The Straight Dope”. On Linear Algebra - Tensors, I get ctypes error when running,

X = nd.arange(24).reshape((2, 3, 4))

The error is,

C:\Anaconda2\lib\site-packages\mxnet\ndarray\ndarray.pyc in reshape(self, *shape, **kwargs)
   1060                                            c_array(ctypes.c_int64, shape),
   1061                                            reverse,
-> 1062                                            ctypes.byref(handle)))
   1063         return NDArray(handle=handle, writable=self.writable)

WindowsError: exception: access violation writing 0x00007FFB00000000

Why is this happening and how can I solve it?

I have tried the same Straight Dope tutorial on my Windows machine with Python 2.7.15 (Anaconda 2) and mxnet version 1.2.0, and it works.

Which version of Windows / Python / MXNet are you using?

1 Like

I have

Python 2.7.14 |Intel Corporation| (default, May  3 2018, 23:35:01) [MSC v.1500 64 bit (AMD64)] on win32

I built MXNET from source (master) with MKL and CUDA. My operating system is Windows 10 Pro.

I downgraded to mxnet 1.2.0 and upgraded to Python 2.7.15 and it solved the problem. Thanks for the help.