1 Like

English version installation guide is not as comprehensive/clear as Chinese version… as expected;)

Thanks. Could you provide some concrete examples that may look unclear?

how about start with having separate paragraphs for Mac and Linux instructions… so real entry level readers (like myself:) do not confuse/have to guess… thanks

Thanks for the feedback! We’ll keep improving the contents to make it clear

@smolix @mli @zack

1 Like

My fault. I wanted to make it less redundant. After all, you have with and without GPU and then Linux, MacOS and Windows. That’s 6 cases.

Please have a look at the updated section and let me know if this works better.

Hi, I’m getting ‘ModuleNotFoundError: No module named ‘mxnet’’ error when trying to import mxnet as mx. I’ve added path to Anaconda3 (i’m on windows 10); I can see package in the folder

have you activated gluon environment?

The link to Miniconda is not working :(. I also had a problem when I was install the last time. In python I can import money, whereas in jupyter notebook it reports not finding the mxnet module.

Please see this link for the miniconda install, indeed their miniconda link seems down for now.

Try to start jupyter in your conda environment so that it picks up automatically the right kernel.

1 Like

The original link is now redirected to:

it is said “Requirement already satisfied: mxnet==1.5.0b20181215 in …” but after I launched jupyter notebook and import mxnet, it happens to me that “no module named mxnet”. Why is that?

1 Like

Have you activated gluon environment?

Thanks. I think it’s the problem of the environment on my computer. It worked after I added the gluon python kernel to my jupyter notebook.

Hello, i’m getting error ‘Could not find a version that satisfies the requirement mxnet==1.5.0b20181215’ during installation of libraries. What can be reason? I’ve installed miniconda with python 3.7 (32-bit).

In windows, after I activate the virtual environment and launch the jupyter notebook I am able to see the folder and the jupyter files. But when I tried to open one I get a 500 error. In the terminal this is the error:

 File "......gluon\lib\site-packages\nbconvert\postprocessors\", line 5, in <module>
        from .serve import ServePostProcessor
 File ".....gluon\lib\site-packages\nbconvert\postprocessors\", line 19, in <module>
        class ProxyHandler(web.RequestHandler):
 File "......gluon\lib\site-packages\nbconvert\postprocessors\", line 21, in ProxyHandler
    AttributeError: module 'tornado.web' has no attribute 'asynchronous'
[E 18:52:20.605 NotebookApp] {
      "Host": "localhost:8888",
      "User-Agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0",
      "Accept": "text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8",
      "Accept-Language": "pt-BR,pt;q=0.8,en-US;q=0.5,en;q=0.3",
      "Accept-Encoding": "gzip, deflate",
      "Referer": "http://localhost:8888/tree/chapter_multilayer-perceptrons",
      "Connection": "keep-alive",
      "Cookie": "csrftoken=IHYtfx7WWC0eIVLXlWzBkNhHHkAgjBkvj9s9FaFBVJM4zManbcJxgUXIikMCpE4e; sessionid=ahsrn5sfjc1kpii81owpf53rky8aszwa; __stripe_mid=9a6290ab-be33-4da3-9f64-5911957d3da9; djdt=hide; username-localhost-8888=\"2|1:0|10:1552502834|23:username-localhost-8888|44:YzkzZjFhN2I2ZWVjNGU4ODlkZGE1NGJhYWQwNGJhNjU=|8e2ef7c00983e57d41c0a96c342865af2c987a108c3f690f478e96343f9cb130\"; _xsrf=2|5c9d76dd|d3935f4e0f4bd8bea3c6ee5b79501f70|1552502834",
      "Upgrade-Insecure-Requests": "1"

I have Anaconda installed on my system, so I haven’t installed Miniconda. I am unable to run the command ‘conda env create -f environment.yml’ in CMD.
It gives an error - ‘‘conda’ is not recognized as an internal or external command,
operable program or batch file.’
Any ideas?

I have followed all the windows installation process with Cuda and it seems like going well.
Once I have tried to open the jupyter notebook the browser opened with the right address http://localhost:8888/tree but the page was blank. What have I missed?

Downgrading the notebook did the trick for me:
pip uninstall notebook
pip install notebook==5.7.4