Install mxnet package in Rstudio Cloud

Hi I tried to install the package mxnet on Rstudio Cloud, which is the cloud version of Rstudio.
I tried it first with R 3.6, then R 3.5.3, neither worked.
I tried from with this piece of code:

cran <- getOption(“repos”)
cran[“dmlc”] <- “
options(repos = cran)

I got a 404 error file not found. THen i tried downloading the .tar.gz installation file associated with LInux/R/CPU;

ERROR: cannot extract package from ‘/cloud/project/apache-mxnet-src-1.5.0-incubating.tar.gz’

THanks for any help with this…

I tried the following and the installation of mxnet package worked fine. Let me know if this fixes your problem.

cran <- getOption("repos")
cran["dmlc"] <- ""
options(repos = cran)

Hi thanks. It gave the same error as previously for me:

HTTP status was ‘404 Not Found’
Error in download.file(url, destfile, method, mode = “wb”, …) :
cannot open URL ‘

Can you confirm that you tested on Rstudio CLoud and not Rstudio standard or a VM? my session info:
R version 3.5.3 (2019-03-11)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 16.04.6 LTS

Update: after some research it seems quite clear that there is no way to install mxnet package on Rstudio Cloud, because the isntallation requires to be logged on terminal with sudo rights, which is forbidden on Rstudio Cloud for now.

Hi @agenis thanks for updating the question with your findings.

I’m not super familiar with Rstudio cloud but do you know if there’s a way create an Rstudio environment with packages pre-installed so that way when you spin up an instance it comes with the packages already built. If that’s the case then the mxnet community could look into distributing MXNet-R that way as well.

Did some digging myself. Looks like Rstudio is still in alpha so they don’t have that functionality yet.