`GPU is not enabled` error [Google Colab]

Hi,

I’m trying to get mxnet to work on Google Colab. I’m using the bert-embedding library which uses mxnet, just in case that’s of help. I have ran !pip instet-cu102all mxn explicitly too, even though bert-embeddings installs it, on Colab and had it imported using import mxnet as [name].

But, to no avail, I keep getting this error message:

MXNetError: [21:52:28] src/ndarray/ndarray.cc:1279: GPU is not enabled

Here is where I ‘call’ the gpu:

from bert_embedding import BertEmbedding
import mxnet as mx
ctx = mx.gpu()
bert_emb = BertEmbedding(dataset_name='wiki_multilingual_cased', ctx=ctx)  # This is the line that throws the error

Like mentioned above, the line that throws the error is when I create a BertEmbedding object, but it’s ultimately a MXNetError. I’ve tried installing CUDA 10.0 or downgrading the MXNet version to mxnet-cu101 or ...-cu100 but I get the same error over and over again.

Some details:

Platform: Google Colab w/ GPU
MXNet Version: Bert installs v1.4.0, I then explicitly tried mxnet-cu100 to -cu102
CUDA version: Tried v10.1 and v10.0

All help is appreciated

http://d2l.ai/chapter_appendix-tools-for-deep-learning/colab.html
First line in my discussion: https://discuss.d2l.ai/t/using-google-colab/424/2

@JustCunn
Please let me know whether it helps you.

And now, we are talking about the management of mxnet.
Your any thoughts maybe helps us.

I actually got the issue resolved, the issue was more in the Python module bert_embedding that was calling mxnet and its requirements. Thanks though for your help and I will make sure to share my thoughts on that GitHub discussion.