Gluoncv TSN tuto: not working


I’m trying to do this tuto because the dataset can’t be downloaded by (unsure if this is expected or an error), I’m using this tuto to prepare it - yet this doesn’t work either:

python returns
Traceback (most recent call last):
File “”, line 357, in
File “”, line 345, in download_ucf101
File “/home/ec2-user/anaconda3/envs/JupyterSystemEnv/lib/python3.6/site-packages/”, line 820, in extractall
self._extract(fnlist, path, pwd)
File “/home/ec2-user/anaconda3/envs/JupyterSystemEnv/lib/python3.6/site-packages/”, line 887, in _extract
check_returncode(p, output)
File “/home/ec2-user/anaconda3/envs/JupyterSystemEnv/lib/python3.6/site-packages/”, line 2868, in check_returncode
raise exc(msg)
rarfile.RarWriteError: Write error [5]: b’Write error in the file /home/ec2-user/.mxnet/datasets/ucf101/UCF-101/PlayingSitar/v_PlayingSitar_g23_c01.avi\nInappropriate ioctl for device’

hardware is EC2 P3.2xl machine
unrar was installed with

tar -zxvf rarlinux-x64-5.5.0.tar.gz
cd rar
sudo cp -v rar unrar /usr/local/bin/

because the snippet provided doesn’t work in the linux of the SageMaker EC2s

I tried to reproduce the problem but for me the script is running fine. I installed the tools via the package manager:

sudo apt-get install unrar
pip install rafile

nice good to know! how did you sudo apt-get install unrar ? on some flavors of linux on EC2 (eg the one in SageMaker EC2s) this is not recognized. Which machine do you use?

I tried it out on Ubuntu DLAMI. You are right that on SageMaker this does not work. Can you try to install a different version of rarlinux?