Colab environment broken/can't import mxnet or d2l

I’ve been using colab for the homeworks, and its been fine until just now. I currently get a “libcudart.so.9.2: cannot open shared object file: No such file or directory” error when importing mxnet or d2l after installation. Anyone else having this issue?

1 Like

Having this issue as well!! Have you found a way to fix this?

I’ve been trying different versions like, mxnet-cu90 and I’ve been getting similar error messages: libcudart.so.9.0: cannot open shared object file: No such file or directory.

I think the install might not be working. Any way to fix this?

This doesn’t work either: https://github.com/googlecolab/colabtools/issues/297

I’ve tried cu80 - 92, none of the versions seems to be working.

turns out they upgraded to cuda 10, using pip install mxnet-cu100 worked for me

2 Likes

pip install mxnet without specifying the version also worked for me. Glad this worked out.

thanks for it. will update the notebooks repo later.

Make sure that MXNet version matches the CUDA, by running on a non-GPU instance first:

!nvcc --version

For detailed working test in Colab see: https://discuss.mxnet.apache.org/t/not-implemented-for-use-with-gpus/1093/5